java1234开源博客系统
博客信息

Maven里添加json-lib支持

0
发布时间:『 2017-02-11 10:01』  博客类别:maven  阅读(3821)

json-lib的maven支持是:

<dependency>
    <groupId>net.sf.json-lib</groupId>
    <artifactId>json-lib</artifactId>
    <version>2.4</version>
</dependency>


但是我们配置到pom.xml里:

QQ鎴浘20170211095715.jpg


QQ鎴浘20170211095725.jpg


报错了;


这里是因为json-lib支持版本是jdk1.5

所以我们要指定下 版本;

<dependency>
	<groupId>net.sf.json-lib</groupId>
	<artifactId>json-lib</artifactId>
	<version>2.4</version>
	<classifier>jdk15</classifier>
</dependency>


这样就OK了

QQ鎴浘20170211100249.png



关键字:   maven     json-lib  
Powered by Java1234 V3.0 Copyright © 2012-2016 Java知识分享网 版权所有